CVE-2026-78254

Data: 2026-09-17

Severity: High

CVSS Score: 7.4 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N)

Nota

La severity e il CVSS Score si riferiscono alla vulnerabilità della libreria. Come descritto nella sezione GovWay, la vulnerabilità non si manifesta nel prodotto, poiché le classi dei task ftp e scp, che contengono il codice vulnerabile, risiedono in artefatti opzionali di Apache Ant non distribuiti da GovWay.

Riferimenti:

Libreria: org.apache.ant:ant (versioni affette: < 1.10.18)

Descrizione

CWE-23: Relative Path Traversal

The ftp and scp tasks of Apache Ant can download files from a remote server. A malicious server can provide relative paths that allow it to write outside of the dedicated target directory for the download, making it possible to overwrite files of the attacker’s choice using the permissions of the user running Ant in versions prior to Ant 1.10.18.

In order to exploit this vulnerability, the server would either have to be malicious or be subject to a machine-in-the-middle attack. Additionally in the case of scp or the ftp task using ftps the server must pass the server identity checks performed by the tasks.

For ftp tasks not using ftps a malicious server could act as a machine-in-the-middle to provide malicious files.

Starting with Ant 1.10.18 both tasks will prevent writing outside of the destination directory by default. An option is available to disable this behavior in the unlikely case that the old behavior is required by existing build files.

Mitigations:

Users of scp and ftp (when using ftps) in any version of Ant should not bypass server identity checks. Users of ftp not using ftps should switch to ftps where possible.

All users are recommended to upgrade to Apache Ant 1.10.18, which fixes this issue.

GovWay

La libreria non fa parte del runtime del gateway: Apache Ant viene distribuito unicamente nella directory lib/antinstaller dell’archivio di installazione, dove costituisce il motore di esecuzione dell’installer del prodotto (AntInstaller), utilizzato per eseguire i task di setup descritti in ant/setup/build.xml. Nessun componente eseguito a runtime dal gateway, dalle console o dai servizi di gestione utilizza la libreria.

Il codice vulnerabile risiede inoltre nelle classi che implementano i task ftp e scp, ossia org.apache.tools.ant.taskdefs.optional.net.FTP e org.apache.tools.ant.taskdefs.optional.ssh.Scp, distribuite da Apache Ant negli artefatti opzionali ant-commons-net e ant-jsch. Tali artefatti non fanno parte della distribuzione di GovWay, che include i soli ant, ant-launcher e ant-apache-regexp: la verifica del contenuto degli archivi effettivamente distribuiti ha confermato l’assenza delle classi sopra indicate, delle quali il file defaults.properties presente in ant.jar riporta unicamente la dichiarazione del nome del task.

L’installazione del prodotto non prevede infine alcun trasferimento di file da server remoti: i task di setup operano esclusivamente sul filesystem locale e sulla base dati indicata dall’amministratore, e nessun file di build utilizza i task ftp, scp o sshexec. Per questi motivi la vulnerabilità non si manifesta nel prodotto.

La libreria viene comunque aggiornata alla prima versione in rilascio.

Versione affette:

  • 3.3.x: <= 3.3.20

  • 3.4.x: <= 3.4.3

Risoluzione:

  • 3.3.x: 3.3.21

  • 3.4.x: 3.4.4