CVE-2026-49875, CVE-2026-50623, CVE-2026-50627, CVE-2026-50628, CVE-2026-50629, CVE-2026-50630, CVE-2026-50631, CVE-2026-50632, CVE-2026-50633, CVE-2026-50634, CVE-2026-50645
Data: 2026-10-19
Severity: Critical / High / Medium
CVSS Score:
CVE-2026-49875: 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
CVE-2026-50628: 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
CVE-2026-50627: 9.1 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H)
CVE-2026-50632: 8.1 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)
CVE-2026-50633: 8.1 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H)
CVE-2026-50645: 7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
CVE-2026-50631: 7.4 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N)
CVE-2026-50630: 6.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N)
CVE-2026-50634: 6.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N)
CVE-2026-50629: 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N)
CVE-2026-50623: 4.8 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N)
Riferimenti:
https://nvd.nist.gov/vuln/detail/CVE-2026-49875 (GHSA-xw5h-cmh3-8j6j)
https://nvd.nist.gov/vuln/detail/CVE-2026-50634 (GHSA-33j8-j763-4fv5)
Libreria: org.apache.cxf (versioni affette: < 3.6.12, 4.0.0 - 4.1.6 e 4.2.0 - 4.2.1)
Descrizione
[CVE-2026-49875] CWE-611: Improper Restriction of XML External Entity Reference
Apache CXF’s EndpointReferenceUtils and W3CMultiSchemaFactory classes construct a SAXParserFactory without the necessary JAXP hardening configurations, enabling out-of-band (OOB) external entity resolution. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fix this issue.
[CVE-2026-50628] CWE-358: Improperly Implemented Security Check for Standard
A logic error in OAuthRequestFilter rejects legitimate requests originating from the bound IP address, while blindly allowing requests from any other IP address. Enabling this security feature inadvertently creates an inverse security check. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50627] CWE-303: Incorrect Implementation of Authentication Algorithm
The JwtAccessTokenValidator class in Apache CXF fails to validate the “aud” (Audience) claims of incoming JWT access tokens. This allows a JWT issued for one Resource Server to be successfully replayed against a completely different Resource Server, leading to Token Confusion/Routing attacks. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50632] CWE-502: Deserialization of Untrusted Data
A further incomplete fix for a previous advisory CVE-2026-44417 (Untrusted JMS configuration can lead to RCE) for Apache CXF has been identified, which can allow code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50633] CWE-502: Deserialization of Untrusted Data
A JNDI Injection vulnerability has been discovered in Apache CXF’s JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50645] CWE-400: Uncontrolled Resource Consumption
There is no restriction on the amount of attachment headers that a message can contain when being deserialized by Apache CXF, which can lead to uncontrolled resource consumption or a denial of service attack. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fix this issue by imposing a maximum default of 500 attachments per message.
[CVE-2026-50631] CWE-367: Time-of-check Time-of-use (TOCTOU) Race Condition
A race condition in AbstractOAuthDataProvider allows concurrent requests using the same Refresh Token to bypass single-use semantics and generate multiple valid Access Tokens, when “recycleRefreshTokens” is set to false. A leaked refresh token can be replayed concurrently by multiple attackers or threads. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50630] CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers (“HTTP Request/Response Splitting”)
A CRLF injection vulnerability exists in the OAuth2 AuthorizationUtils class. When constructing the WWW-Authenticate response header, the “realm” parameter is concatenated without sanitizing Carriage Return (CR) and Line Feed (LF) characters. If an attacker can control the realm value, they can inject arbitrary HTTP headers or split the HTTP response entirely. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50634] CWE-347: Improper Verification of Cryptographic Signature
A vulnerability in Apache CXF’s JwsJsonContainerRequestFilter can be exploited to cause CXF to process metadata that was not authenticated by the accepted signature. This can bypass the application’s assumption that accepted Content-Type or protected HTTP-header metadata came from a verified signature entry, and may steer downstream JAX-RS entity parsing or signed-header consistency checks. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fix this issue.
[CVE-2026-50629] CWE-93: Improper Neutralization of CRLF Sequences (“CRLF Injection”)
The “clientId” parameter from incoming HTTP requests is directly concatenated into OAuth2 server log warning messages without sanitizing control characters. This allows an attacker to inject arbitrary content, including fake log entries, into the server’s log files. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
[CVE-2026-50623] CWE-287: Improper Authentication
An authentication bypass vulnerability exists in the OAuth2 TokenIntrospectionService in Apache CXF. Due to a missing “throw” keyword in the security context check, the introspection endpoint (/services/oauth2/introspect) can be accessed by any unauthenticated network attacker. However note that this is a safeguard only in the case that someone forgot to enable authentication on the service. Users are recommended to upgrade to version 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
Falso Positivo per GovWay
GovWay 3.3.x utilizza Apache CXF in una versione successiva alla 3.6.12, che contiene il fix per tutte le vulnerabilità: come riportato negli advisory ufficiali di Apache CXF, le vulnerabilità sono corrette nelle versioni 4.2.2, 4.1.7 e 3.6.12.
Le segnalazioni derivano dai range di versioni pubblicati nelle banche dati:
l’NVD associa le vulnerabilità alla CPE di prodotto
cpe:2.3:a:apache:cxfcon i soli range< 4.1.7e4.2.0 - 4.2.2, senza distinguere la linea 3.6.x; OWASP dependency-check le rileva quindi a carico degli artefatticxf-core(compresa la versione modificatacxf-core-<versione>-gov4j-<n>) ecxf-rt-transports-http-jetty;gli advisory GitHub GHSA-xw5h-cmh3-8j6j (CVE-2026-49875) e GHSA-33j8-j763-4fv5 (CVE-2026-50634) indicano come versioni corrette solamente la 4.1.7 e la 4.2.2; OSV-Scanner li rileva quindi a carico degli artefatti
cxf-coreecxf-rt-rs-security-jose-jaxrs.
La soppressione OWASP è limitata alle versioni di Apache CXF 3.6.x a partire dalla 3.6.12.
Le valutazioni sull’applicabilità delle singole vulnerabilità alle versioni precedenti di GovWay sono riportate nei rispettivi avvisi di sicurezza (es. CVE-2026-50631, CVE-2026-50623, CVE-2026-50630, CVE-2026-50629, CVE-2026-50632, CVE-2026-50633, CVE-2026-50634, CVE-2026-50645).
Configuration Files: